Selections

To modify part of an image, you first select the area you want to edit. You can move, copy, paint, or apply special effects just to the selected area without affecting the rest of your image. You can choose from a variety of specialized tools for creating selections.

There are separate sets of tools to make selections of bitmap and vector data. To select raster pixels, you can use the marquee tools or the lasso tools; to select vector data, you can use the pen or shape tools, which produce precise outlines called paths. You can convert paths to selections or convert selections to paths.

Making Selections

**Using the Select Menu** - You can use commands in the Select menu to Select All pixels, to Deselect, or to Reselect.

**Using the Marquee Tools** - The Marquee Tools let you select rectangles, ellipses, and 1-pixel rows and columns. By default a Selection border is dragged from its corner.

1. Select the Marquee Tool you want to use, rectangle, ellipse, single row, or single column.
2. In the options bar, specify whether to make a new Selection, add to a Selection, subtract from a Selection, or select an area intersected by other Selections.
3. Specify a feathering setting in the options bar. Turn anti-aliasing on or off for the Elliptical Marquee Tool.
4. For the rectangle, or ellipse Selection tool, choose a style: Normal to determine proportions by dragging, Fixed Aspect Ration to set a height-to-width ratio, or Fixed Size to specify set values for the marquee’s height and width.

5. Do one of the following to make a Selection:
   a) With the rectangle or ellipse tool, drag over the area you want to select. Hold down Shift as you drag to constrain the marquee to a square or circle. To drag a marquee from its center, hold down Alt (win) or Option (mac) after you begin dragging.
   b) With the single row or single column marquee, click near the area you want to select, and then drag the marquee to the exact location. If no marquee is visible, increase the magnification of your image view.

**Using the Lasso Tools** - The Lasso Tool, and the Polygonal Lasso Tool let you draw both straight-edged and freehand segments of a Selection border. With the magnetic Lasso Tool, the border snaps to the edges of defined areas in the image.

**Using the Lasso Tool**

1. Select the Lasso Tool, and select options.
2. Drag to draw a freehand Selection border.
3. To draw a straight-edged Selection border, hold down Alt (win) or Option (mac) and click where segments should begin and end. You can switch between drawing freehand and straight-edged segments.
4. To erase recent segments, hold down Delete until you’ve erased the fastening points for the desired segments.
5. To close the Selection border, release the mouse without holding down Alt (win) or Option (mac).

**Using the Polygonal Lasso Tool**

1. Select the Polygonal Lasso Tool, and select options.
2. Click in the image to select the starting point.
3. Do one or more of the following:
   a) To draw a straight segment, position the point where you want the first straight sement to end, and click. Continue clicking to set endpoints for subsequent segments.
   b) To draw a freehand segment, hold down Alt (win) or Option (mac) and drag. When finished, release Alt or Option and the mouse button.
   c) To recent segments, press Delete.
4. Close the Selection border:
   a) Position the Polygonal Lasso Tool pointer over the starting point, and click.
   b) If the pointer is not over the starting point, double-click the Polygonal Lasso Tool pointer, or Ctrl-click (win) or Command-click (mac).

**Using the Magnetic Lasso Tool**

1. Select the Magnetic Lasso Tool, and select options.
2. Click in the image to set the first fastening point. Fastening points anchor the Selection border in place.
3. To draw a freehand segment, move the points along the edge you want to trace. (You can also draw with the mouse button depressed.) The most recent segment of the Selection border remains active. As you move the pointer, the active segment snaps to the strongest edge in the image, based on the detection Width set in the options bar. Periodically, the Magnetic Lasso Tool adds fastening points to the Selection border to anchor previous segments.
4. If the border doesn’t snap to the desired edge, click once to add a fastening point manually. Continue to trace the edge, and add fastening points as needed.
5. To switch temporary to the other Lasso Tools:
   a) To activate the Lasso Tool, hold down Alt (win) or Option (mac), and drag with the mouse button depressed.
   b) To activate the Polygonal Lasso Tool, hold down Alt (win) or Option (mac), and click.
6. To erase recent segments and fastening points, press Delete until you’ve erased the necessary fastening points.
7. Close the Selection border:
   a) To close the border with a freehand Magnetic segment, double-click, or press Enter or Return.
   b) To close the border with a straight segment, hold down Alt (win) or Option (mac) and double-click.
   c) To close the border, drag back over the starting point and click.

**Setting options for the Lasso Tools** - The Lasso tool op-
Selections

Selections let you customize how the different Lasso Tools detect and select edges.

1. Select the Tool.
2. In the options bar, specify whether you want to create a new Selection, add to an existing Selection, subtract from a Selection, or select an area intersected by other Selections.
3. Specify feather and anti-aliasing options.
4. For the Magnetic Lasso Tool, set any of these options:
   a) To specify a detection width, enter a pixel value for Width. The Magnetic Lasso Tool detects edges only within the specified distance from the pointer.
   b) To specify the Lasso’s sensitivity to edges in the image, enter a value between 1% and 100% for Edge Contrast. A higher value detects only edges that contrast sharply with their surroundings.
   c) To specify the rate at which the Lasso sets fastening points, enter a value between 0 and 100 for frequency. A higher value anchors the Selection border in place more quickly.
   d) To change the Lasso cursor to indicate the Lasso width, press the Caps Lock key. Change the cursor while the tool is selected but not in use.

Using the Magic Wand Tool - The Magic Wand Tool lets you select a consistently colored area without having to trace its outline. You specify the color range, or tolerance, for the Magic Wand Tool’s Selection.

1. Select the Magic Wand Tool.
2. In the options bar, specify whether you want to create a new Selection, add to an existing Selection, subtract from a Selection, or select an area intersected by other Selections. The Magic Wand Tool’s cursor changes depending on which option is selected.
3. For Tolerance, enter a value in pixels, ranging from 0 to 255. Enter a low value to select the few colors very similar to the pixel you click, or enter a higher value to select a broader range of colors.
4. To define a smooth edge, select Anti-Aliased.
5. To select only adjacent areas using the same colors, select Contiguous. Otherwise, all pixels using the same colors will be selected.
6. To select colors using data from all the visible Layers, select Use All Layers. Otherwise, the Magic Wand Tool selects colors from the active Layer only.
7. In the image, click the color you want to select. If Contiguous is selected, all adjacent pixels within the tolerance range are selected. Otherwise, all pixels in the tolerance range are selected.

To move a Selection border

1. Using any Selection tool, select new Selection from the options bar, and position the pointer inside the Selection border. The pointer changes to indicate that you can move the Selection.
2. Drag the border to enclose a different area of the image.

You can drag a Selection border partly beyond the canvas boundaries. When you drag it back, the original border reappears intact. You can also drag the Selection border to another image window.

To control the movement of a Selection

To constrain the direction of movement to multiples of 45 degrees, begin dragging, and then hold down Shift as you continue to drag.

To move the Selection 1-pixel at a time, use the arrow keys.

To move the Selection in 10-pixel increments, hold down Shift and use the arrow keys.

To hide/show Selections edges

Choose Extras > Show or Hide from the View menu. This command also shows or hides Selection edges, grids, guides, target path, slices, and annotations.

To select the unselected parts of an image

Choose Inverse from the Select menu, or press Ctrl+Shift+I (win) or Command+Shift+I (mac)

Adjusting Selections manually - You can use the Selection tools to add to or subtract from existing pixel Selections. Before manually adding to or subtracting from a selection, set the feather and anti-aliased values in the options bar to the same settings used for the original selection.

To add to a Selection or select an additional area

1. Make a Selection.
2. Using any Selection tool:
   a) Select the Add to Selection option in the options bar, and drag.
   b) Hold down Shift, and drag to add another selection.

To subtract from a Selection

1. Make a Selection.
2. Using any Selection tool:
   a) Select the Subtract from Selection option in the options bar, and drag to intersect with other Selections.
   b) Hold down Alt (win) or Option (mac), and drag to add another Selection.

To select only an area intersected by other Selections

1. Make a Selection.
2. Using any Selection tool:
   a) Select the Intersect with Selection option in the options bar, and drag.
   b) Hold down Alt-Shift (win) or Option-Shift (mac), and drag over the portion of the original Selection that you want to Select.

Anti-Aliasing: Anti-Aliasing smooths the jagged edges of a selection by softening the color transition between edge pixels and background pixels. Since only the edge pixels change, no detail is lost. Anti-aliased is useful when cutting, copying, and
Selections

pasting selections to create composite images.

Anti-Aliasing is available for the Lasso Tool, the Polygonal Lasso Tool, the Magnetic Lasso Tool, and the Magic Wand Tool. You must specify this option in the options bar before using these tools. Once a Selection is made, you cannot add anti-aliasing.

**Feathering** blurs edges by building a transition boundary between the Selection and its surrounding pixels. This blurring can cause some loss of detail at the edge of the Selection.

You can define feathering for the Marquee Tool, the Lasso Tool, the Polygonal Lasso Tool, or the Magnetic Lasso Tool in the options bar as you use the tool, or you can add feathering to an existing Selection by choosing Feather in the Select menu. Feathering effects become apparent when you move, cut, copy, or fill the Selection.

**Moving Selections and Layers within an image** - The Move Tool lets you drag a Selection or Layer to a new location in the image. With the Info Palette open, you can track the exact distance of the move. You can also use the Move Tool to align Selections and Layers.

**To specify Move Tool options**

1. Select the Move Tool.
2. Select any of the following in the options bar:
   a) Auto Select Layer to select the topmost layer with pixels under the Move Tool, rather than the selected Layer.
   b) Show Bounding Box to display the bounding box around the selected item.

**To move a Selection or Layer**

1. Select the Move Tool. To activate the Move Tool with another tool selected, press Ctrl (win) or Command (mac).
2. Do one of the following:
   a) Move the pointer inside the Selection border, and drag the Selection to a new position.
   b) Select the Layer you want to move. Then drag the Layer to a new position.

**Copying Selections or Layers** - You can use the Move Tool to copy Selections as you drag them within or between images, or you can copy and move Selections using the Copy, Copy Merged, Cut, and Paste commands. Dragging with the Move Tool saves memory because the Clipboard is not used as it is with the Copy, Copy Merged, Cut and Paste commands.

The Copy command copies the selected area on the active Layer. The Copy Merged command makes a merged copy of all the visible Layers in the selected area.

The Paste command pastes a cut or copied Selection into another part of the image or into another image as a new Layer. If you have a Selection, the Paste command places the copied Selection over the current Selection. Without an active Selection, Paste places the copied Selection in the middle of the view area.

The Paste Into command pastes a cut or copied Selection inside another Selection in the same image or different image. The source Selection is pasted onto a new Layer, and the destination Selection border is converted into a Layer mask.

**To copy a Selection**

1. Select the area you want to copy.
2. Choose Copy or Copy Merged from the Edit menu.

**To copy a Selection while dragging**

1. Select the Move Tool, or hold down Ctrl (win) or Command (mac) to activate the Move Tool.
2. Hold down Alt (win) or Option (mac) and drag the Selection you want to copy and move.

When copying between images, drag the Selection from the active image window into the destination image window. If nothing is selected, the entire active Layer is copied. As you drag the Selection over another image window, a border highlights the window if you can drop the Selection into it.

**Creating multiple copies of a Selection within an image**

1. Select the Move Tool, or hold down Ctrl (win) or Command (mac) to activate the Move Tool.
2. Copy the Selection:
   a) Hold down Alt (win) or Option (mac) and drag the Selection.
   b) To copy the Selection and offset the duplicate by 1 pixel, hold down Alt or Option and press an arrow key.
   c) To copy the Selection and offset the duplicate by 10 pixels, hold down Alt+Shift or Option+Shift and press an arrow key.

As long as you hold down Alt or Option, each press of an arrow key creates a copy of the Selection and offsets it by the specified distance from the last duplicate. In this case, the copy isn’t made on a new Layer.

**Using the Snap command** - Snapping helps with precise placement of selection edges, cropping marquees, shapes, and paths. However, sometimes snapping prevents you from correctly placing elements. You can enable or disable snapping using the Snap command. You can also specify different elements to which you want to snap when snapping is enabled. Choose Snap from the View menu to enable/disable snapping.

**To specify what to snap to** - Choose Snap To from the View menu and choose one or more options from the submenu: Guides, Grid (only when the Grid is not hidden), Document Bounds, All, None. A check mark indicates that the option is selected and snapping is enabled. A dot (win) or dash (mac) indicates that the option is selected, but snapping is disabled.

**Saving and loading Selections** - To save a Selection, choose Save Selection from the Select menu. To load a saved Selection, choose Load Selection from the Select menu, and then enter the options, and click OK.
Selections

Deleting Selections - To delete a Selection, choose Clear from the Edit menu, or press Backspace (win) or Delete (mac). Deleting a Selection on a background or on a Layer with the Lock Transparency option selected in the Layers Palette replaces the original location with the background color. Otherwise, the original area is replaced with the Layer transparency.

Removing fringe pixels from a Selection - When you move or paste an anti-aliased Selection, some of the pixels surrounding the Selection border are included with the Selection. This can result in a fringe or halo around the edges of the pasted Selection. These Matting commands let you edit unwanted edge pixels:

a) Defringe replaces the color of any fringe pixels with the colors of nearby pixels containing pure colors (those without background color). Choose Matting > Defringe from the Layer menu, enter a value in the Width text box for the distance to search for replacement pixels, and click OK.

b) Remove Black Matte and Remove White Matte are useful when you want to paste a Selection anti-aliased against a white or black background onto a different background. Choose Matting > Remove Black Matte or Remove White Matte from the Layer menu.

Using the Extract filter - The Extract filter dialog box provides a sophisticated way to isolate a foreground object and erase its background on a layer. Even objects with wispy intricate, or undefinable edges may be clipped from their backgrounds with a minimum of manual work. You use tools in the Extract dialog box to specify which part of the image to extract.

When you extract the object, Photoshop erases its background to transparency. Pixels on the edge of the object lose their color components derived from background, so they can blend with a new background without producing a color halo.

1. In the Layers Palette, select the Layer containing the object you want to extract. If you select a background Layer, it becomes a normal Layer after the extraction. If the Layer contains a selection, the extraction erases the background only in the Selected area.

2. Choose Extract from the the Filter menu, then specify options for tools on the right side of the dialog box:
   a) For Brush Size, enter a value, or drag the slider to specify the width of the edge highlighter, erase, cleanup, and edge touchup tools.
   b) For Highlight, choose a preset color options for the highlight that appears around objects you choose with the Highlighter tool, or choose Other to specify a custom color for the highlight.
   c) For Fill, choose a preset color option or choose Other to specify a custom color for the area covered by the Fill tool.
   d) If you are highlighting a well-defined edge, select Smart Highlighting. This option helps you keep the highlight on the edge, and applies a highlight that is just wide enough to cover the edge, regardless of the current brush size.

3. Specify Extraction options:
   a) Select Textured Image if the foreground or background of your image contains a lot of texture.
   b) For Smooth, enter a value or drag the slider to increase or decrease the smoothness of the outline.
   c) Select Force Foreground if the object is especially intricate or lacks a clear interior.

4. Adjust the view as needed:
   a) To magnify an area, select the Zoon tool in the dialog box, and click in the preview image. To zoom out, hold down Alt (win) or Option (mac) as you click.
   b) To view a different area, select the Hand tool in the dialog box, and drag in the preview image.
   c) Select Force Foreground if the object is especially intricate or lacks a clear interior.

5. Define the edge of the object you want to extract:
   a) To draw a highlight that marks the edge, select the Edge Highlighter Tool in the dialog box, and drag so that the highlight slightly overlaps both the foreground object and its background. Use Smart Highlighting to trace sharper edges. Use a large brush to cover wispy, intricate edges where the foreground blends into the background, such as hair or trees.
   b) If the object has a well defined interior, make sure that the highlight forms a complete enclosure. You do not need to highlight areas where the object touches the image boundaries. If the object lacks a clear interior, highlight the entire object.
   c) To erase the highlight, select the Eraser Tool in the dialog box, and drag over the highlight. To erase the entire highlight, press Alt+Backspace (win) or Option+Delete (mac).

6. Define the foreground area:
   a) If the object has a well-defined interior, select the Fill tool in the dialog box. Click inside the object to fill its interior.
   b) If you’ve selected Force Foreground, select the Eyedropper tool in the dialog box and click inside the object to sample the foreground color, or click in the Color text box and use a color picker to select the foreground color.

7. Click Preview to preview the extraction
   a) Use Show menu options to switch between previews of the original and extracted image.
   b) Use Display menu options to preview the extracted object against a colored matte background or as a grayscale mask.
   c) Select Show Highlight or Show Fill to display the object’s highlight or fill.

8. Touch up the extraction:
   a) To erase background traces in the extracted area, use the Cleanup tool. The tool subtracts opacity and has a cumulative effect. Hold Alt (win) or Option (mac) while dragging to add opacity back.
   b) To edit the edge of the extracted object, use the Edge Touchup tool. The tool sharpens edges and has a cumulative effect. If there is no clear edge, the Edge Touchup tool adds opacity to the object, or subtracts opacity from the background.
Layers

Layers allow you to work on one element of an image without disturbing the others. Think of layers as sheets of acetate stacked one on top of the other. Where there is no image on a layer, you can see through to the layers below. You can change the composition of an image by changing the order of and attributes of layers. In addition, special features such as adjustment layers, fill layers, and layer styles let you create sophisticated effects. You can put multiple layers together in different ways:

1. Groups let you view and physically manipulate multiple layers as a single object.
2. Sets let you assign attributes to layers as a single object.
3. Links let you link layers to use them as a single object.

The Move tool allows you to move an entire layer (or layers set).

Using the Palette

The Layers palette lists all layers, layer sets, and layer effects in an image. You can accomplish many tasks, such as creating, hiding, displaying, copying, and deleting layers, using the buttons in the Layers palette. You can access additional commands and options in the Layers palette menu and the Layers menu.

- **Displaying the Layers Palette** - Choose Window > Layers. Be sure to move the palette from the dock to enable the palette menu.

- **Using the Layers Palette menu** - Click the triangle in the upper right corner of the palette to access commands for working with layers.

- **Changing the size of the layer thumbnails** - Choose Palette Options from the Layers palette menu, and select a thumbnail size.

- **Expanding and collapsing layer sets** - Click the triangle left of a layer set folder. In Photoshop, press Alt (windows) or Option (mac) when clicking the triangle to expand or collapse all effects applied to layers contained within the set. Press Alt (win) or Option (mac) when clicking the triangle to expand or collapse all sets, including nested sets. Press Ctrl (win) or Command (mac) when clicking to see all sets at the same level as the selected one.

Creating Layers and Sets

A new image in Photoshop has a single layer. The number of additional layers, layer effects and layer sets you can add to an image is limited only by your computer’s memory. When you create a new image with a colored background, the bottom-most image in the layers palette is Background. An image can have only one background. You cannot change the stacking order, blending mode, or opacity of the background. You can convert a background into a regular layer:

1. Double-click the background in the Layers palette, or choose New > Layer from Background from the Layers menu.
2. Set layer options as desired, click OK.

**Creating new Layers and Sets** - You can create empty layers and add content to them, or you can create new layers from existing content. When you create a new layer, it appears either above the selected layer or within the selected layer set in the Layers palette. Methods to create a new Layer or Layer Set:

1. Click the New Layer Button or New Layer Set Button in the Layers Palette. This method uses default options.
2. Set layer options, and click OK.

- **To copy a Layer or Layer Set** - Drag an existing layer or layer set to the New Layer button.

- **To convert a selection into a new Layer** - Make a selection, choose New > Layer Via Copy in the Layer Menu to copy the selection into a new layer.

- **To create a new Layer Set from linked Layers** - Choose New > Layer Set from Linked from the Layer Menu.

- **To add new or existing Layers to a Layer Set** - Select the Layer Set in the Layers Palette and click the New Layer button.
Layers

Working with Layered Images

There are many advantages to working with layered images. You can quickly select, hide, duplicate, lock, and change the appearance of images using layers.

To view/hide Layers within a Set - Click the triangle to the left of the Layer Set name to expand/collapse the contents.

Selecting Layers - If an image has multiple Layers, you must select which layer you want to work on. Any changes you make to the image affect only the active layers. You select a layer to make it active. The name of the active Layer appears in the title bar of the document window and a paintbrush appears next to the Layer in the Layers palette. You can select Layers with the Layers Palette or the Move Tool:

1. After selecting the Move Tool, select Auto Select Layer in the options bar and click the document on the layer content you wish to select. The topmost layer containing pixels under the cursor will be selected. -or-

2. After selecting the Move Tool, right-click in the image, and choose a Layer from the context menu, which lists all the Layers that contain pixels under the current point location.

Displaying the contents of Layers - You can use the Layers Palette to selectively hide and display the contents of Layers, Layer Sets, and Layer Effects. You can also specify how transparent area are displayed in the image.

To change the visibility of a Layer, Layer Set, or Effect - In the Layers Palette, click the eye next to a Layer, Layer Set, or Layer Effect to show/hide its content in the document window.

Duplicating Layers - Duplicating Layers is an easy way to copy content within an image or between images. When duplicating layers between images, keep in mind that the layer's content will appear smaller or larger if it is copied to a file with different resolution.

To duplicate a layer or Layer Set within an image - After selecting a layer or layer set in the Layers Palette, drag the layer or layer set to the New Layer button at the bottom of the Layers Palette.

To duplicate a layer or Layer Set between images

1. Open the source and destination images.
2. In the Layers Palette of the source image, select a Layer or Layer Set.
3. Drag the Layer or Layer Set from the Layers Palette into the destination image.

To create a new document from a Layer or Layer Set

1. Select a Layer or Layer Set in the Layers Palette.
2. Choose Duplicate Layer or Duplicate Layer Set from the Layer menu or the Layers Palette menu.
3. Choose New from the document pop-up menu, click OK.

Changing the Stacking order of Layers - The stacking order in the Layers Palette determines whether the content of a Layer or Layer Set appears in front of or behind other elements in the image.

Drag a Layer or Layer Set up or down in the Layers Palette. Release the mouse button when the highlighted line appears where you want to place the Layer or Layer Set.

To move a Layer into a Layer Set, drag a Layer to the Layer Set Folder. The Layer will be placed at the bottom of the Layer Set.

Linking Layers - By linking two or more Layers or Layer Sets, you can move their contents together. You can also copy, paste, align, merge, apply transformations to, and create clipping masks from linked layers. To link layers:

1. Select a Layer or Layer Set in the Layers Palette.
2. Click in the column immediately to the left of any Layers you want to link to the selected Layer. A link icon appears in the column.

Click the link icon(s) to remove the links.

Aligning Layers - Using the Move Tool, you can a) align either Layers or the contents of Layers and Layers Sets to a selection, or b) link aligned Layers to the content of the active Layer.

In the Move Tool option bar, the following six icons will align Top Edges, Vertical Centers, Bottom Edges, Left Edges, Horizontal Centers, and Right Edges, respectively.

Locking Layers - You can fully or partially lock Layers to protect their contents. For instance, you might want to lock a Layer fully when you finish with it. Another Layer might have the correct transparency, but you are still deciding on positioning, so you want to leave that Layer partially locked. When a Layer is locked, a lock icon displays to the right of the Layer name. The lock options are:

- Lock Transparent Pixels
- Lock Image Pixels
- Lock Position
- Lock All

Sampling from Layers - The default behaviour of the Magic Wand, Smudge, Blur, Sharpen, Paint Bucket, Clone Stamp, and Healing Brush Tools is to sample color only from pixels on the active Layer. This means you can smudge or sample in a single Layer even when other Layers are visible, and you can sample from one Layer and paint in another one.

Alternatively, you can choose to paint using sampled data from all visible Layers: Select one of the Tools listed above, and in the options bar, select Use All Layers.
Renaming Layers - As you add Layers to an image, it can be helpful to rename Layers based on their content. Using descriptive Layer names allows you to easily identify Layers in the Layers Palette. You can either double-click the Layer or Layer Set’s name in the Layers Palette and enter a new name, or select a Layer or Layer Set and choose Layer Properties or Layer Set Properties from the Layer menu or the Layers Palette menu.

Color Coding Layers - Color coding Layers and Layer Sets makes it easier to locate related Layers in the Layers Palette.

1. Select a Layer or Layer Set, and choose Layer Properties or Layer Set Properties from the Layers menu or the Layers Palette menu.
2. Choose a color from the Color pop-up menu, click OK.

Rasterizing Layers - You cannot use the painting tools or filters on Layers that contain vector data (such as Type Layers, Shape Layers, and Vector Masks) and generated data (such as Fill Layers). However, you can rasterize these Layers to convert their contents into a flat raster image.

To rasterize a single Layer - After selecting the Layer you want to rasterize, choose Rasterize from the Layer menu, and choose an option from the submenu.

To rasterize multiple Layers - You can either link the Layers you want to rasterize, and choose Rasterize > Linked Layers from the Layer menu, or choose Rasterize > All Layers from the Layer menu to rasterize all Layers that contain vector and generated data.

Deleting Layers - Deleting Layers that you no longer need reduces the size of your image file. After selecting a Layer or Layer Set in the Layers Palette, click the trash button or drag the Layer or Layer Set to the trash button (on the Layers Palette).

Choose Delete Hidden Layers from the Layer menu or the Layers Palette menu to delete hidden Layers.

Merging Layers - When you have finalized the content of Layers, you can merge them to create partial versions of your composite image. This helps you manage the size of your image files. When you merge Layers, the data on the top Layers replaces the data it overlaps on the lower Layers. The intersection of all transparent areas in the merged Layers remains transparent.

When you save a merged document, you cannot revert to the unmerged state; the Layers are permanently merged.

To merge two Layers or Layer Sets
1. Position the Layers or Layer Sets you want to merge next to each other in the Layers Palette, and make sure the visibility for both items is enabled.
2. Select the top item in the pair.
3. Choose Merge Down or Merge Layer Set from the Layer menu or Layers Palette menu.

To merge all visible linked Layers - Choose Merge Linked from the Layer menu or the Layers Palette menu.

To merge all visible Layers and Layer Sets in an image - Choose Merge Visible from the Layer menu or the Layers Palette menu.

Stamping Layers - In addition to merging Layers, you can stamp Layers. Stamping allows you to merge the contents of more than one Layer into a target Layer while leaving the other Layers intact.

To stamp Layers
1. Position the Layer you want to stamp from above the Layer you want to stamp to, and make sure that the visibility for both Layers is enabled.
2. Select the top item in the pair.
3. Press Ctrl+Alt+E (win) or Command+Option+E (mac).

To stamp linked Layers - Select one of the linked Layers, and press Ctrl+Alt+E (win) or Command+Option+E (mac). The selected Layer is stamped with the contents from the other linked Layers.

To stamp all visible Layers in an image - Select the Layer or Layer Set that you want to contain the new contents, and press Shift+Ctrl+Alt+E (win) or Shift+Command+Option+E (mac).

Flattening all Layers - In a flattened image, all visible Layers are merged into the background, which greatly reduces the file size. Flattening an image discards all hidden Layers and fills the remaining transparent areas with white. In most cases, you won’t want to flatten a file until you have finished editing the individual Layers. To flatten an image:

1. Make sure all the Layers you want to keep are visible.
2. Choose Flatten Image from the Layer menu or the Layers Palette menu.

To flatten all visible linked Layers - Choose Merge Linked from the Layer menu or the Layers Palette menu.

Tracking File Size - File size depends on the pixel dimensions of an image and the number of Layers contained in the image. Images with more pixels may produce more detail when printed, but they require more disk space to store and may be slower to edit and print. You should keep track of your file sizes to make sure the files are not becoming too large for your purposes. If the file is becoming too large, reduce the number of Layers in the image or change the image size.

You can view file size information for an image at the bottom of the application window (win) or document window (mac).